Microsoft Excel. От основ к задачам обработки и представления данных. Степанченко И.В. - 113 стр.

UptoLike

Составители: 

115
Формула вида: =СУММЕСЛИ($AT$17:$AT$316;$AT$10) суммиру-
ет ячейки, находящиеся в столбце AT, при условии, что они равны (по
значению) ячейке AT10, т. е. в нашем случае размеру стипендии троеч-
ника-хорошиста. Абсолютные ссылки не позволяют измениться формуле
при копировании.
Аналогично можно подсчитать сумму стипендиального фонда от-
личников, только необходимо изменить адрес
ячейки, содержащей раз-
мер одной стипендии отличника (в таблице это ячейка AK10).
8.2.7. Вычисление процентных отношений
Вычисление процентного отношения Вам знакомо еще со школы и
каких-либо трудностей не представляет. Формулы, вычисляющие про-
цент, просты и Вы сможете изучить их реализацию в Excel самостоятель-
но. Единственной особенностью является то, что умножение на
100% в
Excel не нужно. Достаточно указать процентный формат ячеек. Это мож-
но выполнить через меню «Формат» пункт «Ячейки», вкладку «Число».
Либо вызвав контекстное меню правой кнопкой мыши и командой
«Формат ячеек», либо через панель инструментов «Форматирование»
нажав на кнопку «Процентный формат»
.
Замечание. Одной из особенностей вычисления процентов является то, что
при вычислении процентов для округленных чисел (или при округлении процентов)
может получиться ситуация, что сумма процентов не будет равняться 100 %,
а будет отличаться в последнем знаке (в меньшую сторону).
8.2.8. Вычисление среднего балла
по предметам и определение максимального из них
Средний балл по предметам находится суммированием всех оценок
в соответствующем столбце и делением их на число студентов. Формула,
определяющая средний балл по математике (первому предмету), имеет
вид: =СУММ(AB$16:AB$317)/ЧСТРОК($AB$17:$AB$316).
Обе функции Вам уже знакомы, адресация суммы
имеет одну абсолют-
ную ссылкустрокам, так как при копировании этой формулы в другую
ячейку должен измениться предмет, по которому определяется средний балл.
Для определения максимального балла из средних по предметам
можно использовать функцию МАКС: =МАКС(AW37:AW48).
Диапазон ячеек с AW37 по AW48 содержит средние баллы по пред-
метам. Определение
же названия предмета немного сложнее.
="П"&ТЕКСТ(ПОИСКПОЗ(МАКС(AW37:AW48);AW37:AW48;0);"0")
Функция ПОИСКПОЗ возвращает относительное положение эле-
мента массива, который соответствует заданному значению указанным
    Формула вида: =СУММЕСЛИ($AT$17:$AT$316;$AT$10) суммиру-
ет ячейки, находящиеся в столбце AT, при условии, что они равны (по
значению) ячейке AT10, т. е. в нашем случае размеру стипендии троеч-
ника-хорошиста. Абсолютные ссылки не позволяют измениться формуле
при копировании.
    Аналогично можно подсчитать сумму стипендиального фонда от-
личников, только необходимо изменить адрес ячейки, содержащей раз-
мер одной стипендии отличника (в таблице это ячейка AK10).

               8.2.7. Вычисление процентных отношений
     Вычисление процентного отношения Вам знакомо еще со школы и
каких-либо трудностей не представляет. Формулы, вычисляющие про-
цент, просты и Вы сможете изучить их реализацию в Excel самостоятель-
но. Единственной особенностью является то, что умножение на 100% в
Excel не нужно. Достаточно указать процентный формат ячеек. Это мож-
но выполнить через меню «Формат» пункт «Ячейки», вкладку «Число».
Либо вызвав контекстное меню правой кнопкой мыши и командой
«Формат ячеек», либо через панель инструментов «Форматирование»
нажав на кнопку «Процентный формат»       .
     Замечание. Одной из особенностей вычисления процентов является то, что
при вычислении процентов для округленных чисел (или при округлении процентов)
может получиться ситуация, что сумма процентов не будет равняться 100 %,
а будет отличаться в последнем знаке (в меньшую сторону).

                     8.2.8. Вычисление среднего балла
             по предметам и определение максимального из них
     Средний балл по предметам находится суммированием всех оценок
в соответствующем столбце и делением их на число студентов. Формула,
определяющая средний балл по математике (первому предмету), имеет
вид: =СУММ(AB$16:AB$317)/ЧСТРОК($AB$17:$AB$316).
     Обе функции Вам уже знакомы, адресация суммы имеет одну абсолют-
ную ссылку – строкам, так как при копировании этой формулы в другую
ячейку должен измениться предмет, по которому определяется средний балл.
     Для определения максимального балла из средних по предметам
можно использовать функцию МАКС: =МАКС(AW37:AW48).
     Диапазон ячеек с AW37 по AW48 содержит средние баллы по пред-
метам. Определение же названия предмета немного сложнее.
="П"&ТЕКСТ(ПОИСКПОЗ(МАКС(AW37:AW48);AW37:AW48;0);"0")
     Функция ПОИСКПОЗ возвращает относительное положение эле-
мента массива, который соответствует заданному значению указанным

                                    115