Microsoft Excel. От основ к задачам обработки и представления данных. Степанченко И.В. - 110 стр.

UptoLike

Составители: 

112
Для сравнения в Excel есть функция ЕСЛИ. Данная функция воз-
вращает одно значение, если заданное условие при вычислении дает зна-
чение ИСТИНА (условие выполняется), и другое значение, если ЛОЖЬ
(условие не выполняется). Функция ЕСЛИ используется для условной
проверки значений и формул.
Примеры
.
1. В следующем примере, если значение ячейки A10 равно 100, то
условие выполняется, т. е. имеет значение ИСТИНА и вычисляется сум-
ма для ячеек B5:B15. В противном случае условие не выполняется, т. е.
имеет значение ЛОЖЬ и возвращается пустой текст (""), очищающий
ячейку, которая содержит функцию ЕСЛИ.
=ЕСЛИ(A10=100;СУММ(B5
:B15);"")
2. Предположим, что рабочий лист по расходам содержит в ячейках
B2:B4 фактические расходы за январь, февраль, март: 1500, 500 и 500
соответственно. Ячейки C2:C4 содержат данные по предполагаемым рас-
ходам за те же периоды: 900, 900 и 925. Можно написать формулу для
проверки соответствия бюджету расходов определенного месяца, генери-
руя тексты сообщений с
помощью следующих формул:
=ЕСЛИ(B2>C2;"Превышение бюджета";"")
условие выполняется, значение в ячейке с условием равняется "Пре-
вышение бюджета";
=ЕСЛИ(B3>C3;"Превышение бюджета";"")
условие не выполняется, значение в ячейке с условием равняется "".
Замечание. До семи функций ЕСЛИ могут быть вложены друг в друга в каче-
стве значений аргументов.
В нашем случае для диагностирования двух категорий студентов не-
обходимо проверить количество двоек (если оно не равно нулю, то сту-
дент двоечник) и количество пятерок (если оно равно количеству пред-
метов, т. е. 12, то студент отличник). В ячейке AS17 записана соответст-
вующая формула:
=ЕСЛИ(AO17<>0;"двоечник";ЕСЛИ(AR17=12;"отличник";""))
Обратим
внимание на то, что второе условие ЕСЛИ проверяется в
том случае, когда первое условие не выполняется, т. е. имеет значение
ЛОЖЬ. Если продолжить написание условий, то, поставив условие в
качестве третьего аргумента вложенной функции ЕСЛИ, можно опреде-
лить и троечников и хорошистов:
=ЕСЛИ(AO17<>0;"двоечник";
ЕСЛИ(AR17=12;"отличник";
ЕСЛИ(AP17<>0;"
троечник","хорошист"))).
     Для сравнения в Excel есть функция ЕСЛИ. Данная функция воз-
вращает одно значение, если заданное условие при вычислении дает зна-
чение ИСТИНА (условие выполняется), и другое значение, если ЛОЖЬ
(условие не выполняется). Функция ЕСЛИ используется для условной
проверки значений и формул.
     Примеры.
     1. В следующем примере, если значение ячейки A10 равно 100, то
условие выполняется, т. е. имеет значение ИСТИНА и вычисляется сум-
ма для ячеек B5:B15. В противном случае условие не выполняется, т. е.
имеет значение ЛОЖЬ и возвращается пустой текст (""), очищающий
ячейку, которая содержит функцию ЕСЛИ.
                    =ЕСЛИ(A10=100;СУММ(B5:B15);"")
     2. Предположим, что рабочий лист по расходам содержит в ячейках
B2:B4 фактические расходы за январь, февраль, март: 1500, 500 и 500
соответственно. Ячейки C2:C4 содержат данные по предполагаемым рас-
ходам за те же периоды: 900, 900 и 925. Можно написать формулу для
проверки соответствия бюджету расходов определенного месяца, генери-
руя тексты сообщений с помощью следующих формул:
                 =ЕСЛИ(B2>C2;"Превышение бюджета";"")
     условие выполняется, значение в ячейке с условием равняется "Пре-
вышение бюджета";
                 =ЕСЛИ(B3>C3;"Превышение бюджета";"")
     условие не выполняется, значение в ячейке с условием равняется "".
Замечание. До семи функций ЕСЛИ могут быть вложены друг в друга в каче-
стве значений аргументов.
    В нашем случае для диагностирования двух категорий студентов не-
обходимо проверить количество двоек (если оно не равно нулю, то сту-
дент двоечник) и количество пятерок (если оно равно количеству пред-
метов, т. е. 12, то студент отличник). В ячейке AS17 записана соответст-
вующая формула:
       =ЕСЛИ(AO17<>0;"двоечник";ЕСЛИ(AR17=12;"отличник";""))
    Обратим внимание на то, что второе условие ЕСЛИ проверяется в
том случае, когда первое условие не выполняется, т. е. имеет значение
ЛОЖЬ. Если продолжить написание условий, то, поставив условие в
качестве третьего аргумента вложенной функции ЕСЛИ, можно опреде-
лить и троечников и хорошистов:
     =ЕСЛИ(AO17<>0;"двоечник";
     ЕСЛИ(AR17=12;"отличник";
     ЕСЛИ(AP17<>0;"троечник","хорошист"))).

                                  112